Communication problem between agents

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Communication problem between agents

Rao Asif
Hi,

I am working on 12 agents, 3 in a group, total of 4 groups, i am trying to establish communication with in a group (3 nodes communicate with each other in a group about their status).

The environment is simulating but the log is not working, if anybody could give me any hint? what and where the problem could be?
Or what information i must give you so that any body can answer this problem.


Regards,
Asif Zafar





Smile Plz



Get a new e-mail account with Hotmail - Free. Sign-up now.
------------------------------------------------------------------------------


_______________________________________________
Jason-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jason-users
Reply | Threaded
Open this post in threaded view
|

Re: Communication problem between agents

Rao Asif

HI,

I have adjusted the logging settings as in miner's example, than we have created jar file and placed it in the lib folder kindly tell me :

what are the other 'jar' files to be added in lib?

even than i was not getting any out put except environment,

Than after studying the infrastructure used in Jason i come to know that default infrastructure is centralized but our aim is to implement the distributed infrastructure and to communicate agents independent.

When i added "Jade" as infrastructure in .mas2j file at once i got the status of all the agents (12 agents) as:

[temp1] starting temp1
[temp4] starting temp4
[temp2] staring temp2
[gas4] starting gas4
[gas2] starting gas2
[air1] starting air1
.
.
.
.
. so on for all ... randomly.

I need to know all the required configurations of jade in j-edit (Jason) 
e.g jar file = ?
logging parameters = ?
and the jade classes to be imported in my classes.

Do you think i am in right direction?

I am not getting the communication of the agents and their responses as out put in logging file.

Thank you for your cooperation as i am new user to Jason.


Regards,
Asif Zafar

Halmstad University
Sweden.


Smile Plz



> Subject: Re: [Jason-users] Communication problem between agents
> From: [hidden email]
> Date: Mon, 24 May 2010 14:22:14 -0300
> CC: [hidden email]
> To: [hidden email]
>
> Hi Asif, you could also report what exactly is not working.
> Regards,
> Jomi
>
> On 24/05/2010, at 13:49, Rafael H Bordini wrote:
>
> > Did you check the info in the FAQ?
> > see jason.sf.net/faq
> > section 4.3 is about logging
> > cheers
> > Rafael
> >
> >
> > Rao Asif wrote:
> >> Hi,
> >> I am working on 12 agents, 3 in a group, total of 4 groups, i am trying to establish communication with in a group (3 nodes communicate with each other in a group about their status).
> >> The environment is simulating but the log is not working, if anybody could give me any hint? what and where the problem could be?
> >> Or what information i must give you so that any body can answer this problem.
> >> Regards,
> >> Asif Zafar
> >> /*Smile Plz*/
> >> ------------------------------------------------------------------------
> >> Get a new e-mail account with Hotmail - Free. Sign-up now. <http://clk.atdmt.com/UKM/go/197222280/direct/01/>
> >> ------------------------------------------------------------------------
> >> ------------------------------------------------------------------------------
> >> ------------------------------------------------------------------------
> >> _______________________________________________
> >> Jason-users mailing list
> >> [hidden email]
> >> https://lists.sourceforge.net/lists/listinfo/jason-users
>
> --
> Jomi Fred Hubner
> Federal University of Santa Catarina
> Department of Automation and Systems Engineering
> PO Box 476, Florianópolis, SC
> 88040-900 Brazil
> http://www.das.ufsc.br/~jomi
>


Get a free e-mail account with Hotmail. Sign-up now.
------------------------------------------------------------------------------


_______________________________________________
Jason-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jason-users
Reply | Threaded
Open this post in threaded view
|

Re: Communication problem between agents

Jomi Fred Hubner-4

On 25/05/2010, at 15:32, Rao Asif wrote:

>
> HI,
>
> I have adjusted the logging settings as in miner's example, than we have created jar file and placed it in the lib folder kindly tell me :
>
> what are the other 'jar' files to be added in lib?

all extra jars (e.g. jgraph.jar). jason.jar, saci.jar, jade*.jar are included automatically from the Jason installation path.

>
> even than i was not getting any out put except environment,
>
> Than after studying the infrastructure used in Jason i come to know that default infrastructure is centralized but our aim is to implement the distributed infrastructure and to communicate agents independent.
>
> When i added "Jade" as infrastructure in .mas2j file at once i got the status of all the agents (12 agents) as:
>
> [temp1] starting temp1
> [temp4] starting temp4
> [temp2] staring temp2
> [gas4] starting gas4
> [gas2] starting gas2
> [air1] starting air1
> .
> .
> .
> .
> . so on for all ... randomly.
>
> I need to know all the required configurations of jade in j-edit (Jason)
> e.g jar file = ?
> logging parameters = ?
> and the jade classes to be imported in my classes.
>
> Do you think i am in right direction?

Does the getting started example (http://jason.sourceforge.net/mini-tutorial/getting-started/) work for you?

Usually you simply need to press the "play" button, no special configuration is necessary. BTW, for what are your customising the logging system?

Regards,

Jomi

>
> I am not getting the communication of the agents and their responses as out put in logging file.
>
> Thank you for your cooperation as i am new user to Jason.
>
>
> Regards,
> Asif Zafar
>
> Halmstad University
> Sweden.
>
>
> Smile Plz
>
>
>
> > Subject: Re: [Jason-users] Communication problem between agents
> > From: [hidden email]
> > Date: Mon, 24 May 2010 14:22:14 -0300
> > CC: [hidden email]
> > To: [hidden email]
> >
> > Hi Asif, you could also report what exactly is not working.
> > Regards,
> > Jomi
> >
> > On 24/05/2010, at 13:49, Rafael H Bordini wrote:
> >
> > > Did you check the info in the FAQ?
> > > see jason.sf.net/faq
> > > section 4.3 is about logging
> > > cheers
> > > Rafael
> > >
> > >
> > > Rao Asif wrote:
> > >> Hi,
> > >> I am working on 12 agents, 3 in a group, total of 4 groups, i am trying to establish communication with in a group (3 nodes communicate with each other in a group about their status).
> > >> The environment is simulating but the log is not working, if anybody could give me any hint? what and where the problem could be?
> > >> Or what information i must give you so that any body can answer this problem.
> > >> Regards,
> > >> Asif Zafar
> > >> /*Smile Plz*/
> > >> ------------------------------------------------------------------------
> > >> Get a new e-mail account with Hotmail - Free. Sign-up now. <http://clk.atdmt.com/UKM/go/197222280/direct/01/>
> > >> ------------------------------------------------------------------------
> > >> ------------------------------------------------------------------------------
> > >> ------------------------------------------------------------------------
> > >> _______________________________________________
> > >> Jason-users mailing list
> > >> [hidden email]
> > >> https://lists.sourceforge.net/lists/listinfo/jason-users
> >
> > --
> > Jomi Fred Hubner
> > Federal University of Santa Catarina
> > Department of Automation and Systems Engineering
> > PO Box 476, Florianópolis, SC
> > 88040-900 Brazil
> > http://www.das.ufsc.br/~jomi
> >
>
> Get a free e-mail account with Hotmail. Sign-up now. ------------------------------------------------------------------------------
>
> _______________________________________________
> Jason-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/jason-users

--
Jomi Fred Hubner
Federal University of Santa Catarina
Department of Automation and Systems Engineering
PO Box 476, Florianópolis, SC
88040-900 Brazil
http://www.das.ufsc.br/~jomi


------------------------------------------------------------------------------

_______________________________________________
Jason-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jason-users